Surendra Sharma

Surendra Sharma

Search This Blog

Showing posts with label sitecore92. Show all posts
Showing posts with label sitecore92. Show all posts

Wednesday, September 18, 2019

Enable Unicorn for Sitecore websites


Below files are required in order to enable Unicorn on any Sitecore website i.e. if you want to access http://<sitecorewebiste>/Unicorn.aspx, put below files in bin folder
  • Configy.dll
  • Kamsar.WebConsole.dll
  • MicroCHAP.dll
  • Rainbow.dll
  • Rainbow.Storage.Sc.dll
  • Rainbow.Storage.Yaml.dll
  • Unicorn.dll

Config files

  • All config files under "App_Config\Include\Unicorn" folder
  • Rainbow.config

You should make your own project sepcific config file to serialize Sitecore items using Unicorn.

For JSS App, you can create unicorn file "Include\zzz\JSS.Serialization.config" something like 

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">

  <sitecore>
    <unicorn>
      <configurations>
        <configuration name="SitecoreJSSUnicorn" description="Sitecore JSS Serilization using Unicorn">
          <targetDataStore physicalRootPath="D:\Projects\MyJSSProject\Sitecore\Serialization\JSS Site Items" useDataCache="false" type="Rainbow.Storage.SerializationFileSystemDataStore, Rainbow" singleInstance="true"/>
          <predicate type="Unicorn.Predicates.SerializationPresetPredicate, Unicorn" singleInstance="true" >
            <!--Media-->
            <include name="SitecoreUnicorn.MediaOuter.JSS" database="master" path="/sitecore/media library/products-myjssproject">
              <!-- <exclude children="true"/> -->
            </include>
            <!--Media-->
            <include name="SitecoreUnicorn.MediaInside.JSS" database="master" path="/sitecore/media library/Project/JSSTenant/products-myjssproject">
              <!-- <exclude children="true"/> -->
            </include>           
            <!--Tempaltes-->
            <include name="SitecoreUnicorn.Template.JSS" database="master" path="/sitecore/templates/Project/products-myjssproject">
              <!-- <exclude children="true"/> -->
            </include>
            <include name="SitecoreUnicorn.Placeholders.JSS" database="master" path="/sitecore/layout/Placeholder Settings/Project/products-myjssproject">
              <!-- <exclude children="true"/> -->
            </include>
            <include name="SitecoreUnicorn.Layout.JSS" database="master" path="/sitecore/layout/Layouts/Project/products-myjssproject">
              <!-- <exclude children="true"/> -->
            </include>
            <include name="SitecoreUnicorn.Renderings.JSS" database="master" path="/sitecore/layout/Renderings/Project/products-myjssproject">
              <!-- <exclude children="true"/> -->
            </include>
            <include name="SitecoreUnicorn.Content.JSS" database="master" path="/sitecore/content/MyJSSTenant/products-myjssproject">
              <!-- <exclude children="true"/> -->
            </include>                  
          </predicate>
        </configuration>
      </configurations>
    </unicorn>
  </sitecore>
</configuration>


Friday, September 13, 2019

How to use Express Migration Tool for Sitecore 9.2

Sitecore Express Migration Tool is used to migrate from version 6.6 to 9.0 initial version. But latest version of Sitecore is 9.2.

Can you export content from any instance of Sitecore 6.6 and onwards to dircetly to Sitecore 9.2?

The answer is YES. Question is how?

So here is the trick!!!

We will use the Sitecore Express Migration Tool itself for this. We will select our needed Source Sitecore version and target Sitecore version as 9.0.0 rev. 171002 and select options to migrate as

  • Core database items
  • Master database items
  • Security
We are ONLY migrating content and NOT the files. So finally you tool screen should looks like

Step 1 in Sitecore Express Migration Tool
Step 1 : Sitecore Express Migration Tool


Click "Next" button.

This tool migrate items from one database to another database. If we compare CORE and MASTER database of earlier version with Sitecore 9.2 version. Tables number and structure is same. If you think logically, all sitecore versions have "Items" table. So it does not matter which Sitecore version are you using.


Sitecore 9.2 Vs 7.2 Database Tables Comparison
Sitecore 9.2 Vs 7.2 Database Tables Comparison

So in step 2 Source section, you can put connection string of your old Sitecore instance details but in "Target" section, you have to specify your Sitecore 9.2 related CORE and MASTER database connection string. Though we are not copying any files but still you should specify Website folder for 9.2. It will be similar to below screen

Step 2 in Sitecore Express Migration Tool
Step 2 : Sitecore Express Migration Tool


Now you can continue ahead with tool and this migration should be completed successfully.

After completion either Recycle your app pool or restart IIS.


Open your Sitecore 9.2 instance and you should get your all old Sitecore instance items in 9.2 content tree.

I have tested it on my local machine and it works like a charm.

So Happy migration!!!

Wednesday, September 11, 2019

Fixed : Access Issue while importing JSS app

If you are getting error when you fire Sitecore JSS command jss deploy app -c -d

Exception thrown while importing JSS app
Exception: Sitecore.Exceptions.AccessDeniedException
Message: AddFromTemplate - Add access required (destination: {0DE95AE4-41AB-4D01-9EB0-67441B7C2450}, template: {061CBA15-5474-4B91-8A06-17903B102B82})


Solution:-
 

Id "{0DE95AE4-41AB-4D01-9EB0-67441B7C2450}" is for "/sitecore/content" while "{061CBA15-5474-4B91-8A06-17903B102B82}" is for "/sitecore/templates/Foundation/JavaScript Services/App".
 

Basically JssImport service unable to create item under "Content" item. So this is the permission problem.

To fix it, provide access to user "sitecore\JssImport" to "Sitecore\Content" and its descendant items as


Permission to user JssImport
Permission to user JssImport

 

Friday, September 6, 2019

How to install Sitecore 9.0 with SIF 2.1.0

As you know to install Sitecore 9.0 , you need SIF 1.2.1. But with below modifications you can install Sitecore 9.0 with SIF 2.1.0 as well. For this

  • Modify xconnect-createcert.json -> Find the CreateRootCert task -> Change the StoreLocation from CurrentUser to LocalMachine
  • Modify xconnect-solr.json and sitecore-solr.json -> Find the CreateCores task in each file -> Change the "Name" attribute in Params > Action to lowercase "name".

So now with single SIF version 2.1.0, you can install 9.0 and 9.2 instance.

Thursday, September 5, 2019

Fixed - Failed to start service Sitecore XConnect Search Indexer

If you are installing Sitecore 9/9.1/9.2, you may get xConnect services error such as

Faulting application name: XConnectSearchIndexer.exe, version: 3.0.0.0, time stamp: 0xf3556d61
Faulting module name: KERNELBASE.dll, version: 10.0.18362.1, time stamp: 0x1a30e11b
Exception code: 0xe0434352
Fault offset: 0x000000000003a839
Faulting process id: 0x1dd8
Faulting application start time: 0x01d563cefdbb60d1
Faulting application path: C:\inetpub\wwwroot\habitathomecorporate_xconnect.dev.local\App_Data\jobs\continuous\IndexWorker\XConnectSearchIndexer.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report Id: bee07631-f2fa-48b6-9307-b4296f68ff50
Faulting package full name:
Faulting package-relative application ID:


Solution :-

I follow below steps and its solved my issue
  • Close all PowerShell window
  • Remove any existing "DO_NOT_TRUST_SitecoreRootCert" certificate from your machine
  • Provide "Full Permission" to "Everyone" to folder "c:\resourcefiles"
  • Provide "Full Permission" to "Everyone" to folder "C:\inetpub\wwwroot.

Try again to install the Sitecore and you should get your instance up now.

I hope this solution helps other in similar situation.

Thursday, August 15, 2019

Why to upgrade Sitecore from 8.2 to 9.2

If you are running any Sitecore website in 8.x, then start to plan on its upgradation. 

Question is Why? 

Well, first thing is that mainstream support of Sitecore version 8.2 is going to end in 31st Dec 2019. However extended support will be avilable upto 31-Dec-2022. But remember there will be cost associated for providing any patch, hotfixes, DLL or development defects solution during this extended period by Sitecore.

Second MongoDB 3.4 is generally used for Sitecore 8.2 and bad news is that MongoDB 3.4 will also end its support in Jan 2020.

So I will suggest to all clients, sitecore license holders to upgrade their projects from 8.2 to latest version of Sitecore 9.2. Sitecore 9.2 comes with cutting-edge features.

Just a note Sitecore 9.2 Mainstream Support will be available upto 31st Dec 2022.

Wednesday, August 14, 2019

Certificate : Installing Sitecore XP0 9.2

Though not a big deal, but I have one hour of time and I utilize it to complete the course "Installing Sitecore® XP0 9.2" from Sitecore elearning.

Here is the certificate for the same.

 Installing Sitecore XP0 9.2
 Installing Sitecore XP0 9.2

Tuesday, August 13, 2019

Certificate : Fast-Track Design in Sitecore Experience Accelerator 9.2

Today I continue my SXA journey, completed the course "Fast-Track Design in Sitecore® Experience Accelerator 9.2" from Sitecore elearning.

Here is the certificate for the same.

Fast-Track Design in Sitecore® Experience Accelerator 9.2
Fast-Track Design in Sitecore® Experience Accelerator 9.2

Monday, August 12, 2019

Certificate : Introduction to Sitecore Experience Accelerator 9.2

Today I get started to familiar myself with Sitecore SXA. For this I choose two courses from elearning and completed one of them. I received certificate for course "Introduction to Sitecore Experience Accelerator 9.2" after completion of this course.

Here is the certificate.

 
Introduction to Sitecore Experience Accelerator 9.2
Introduction to Sitecore Experience Accelerator 9.2